Aller au contenu

Core Network

FRR-1

!
frr version 8.4.1
frr defaults traditional
hostname FRR-1
log syslog informational
!
interface eth2
 ipv6 address 2001:db8:15::1/64
 ipv6 router isis SRv6
 isis circuit-type level-1
exit
!
interface eth0
 ipv6 address 2001:db8:31::1/64
 ipv6 router isis SRv6
 isis circuit-type level-1
exit
!
interface eth1
 ipv6 address 2001:db8:12::1/64
 ipv6 router isis SRv6
 isis circuit-type level-1
exit
!
interface lo
 ipv6 address 2001:db8:11::1/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 isis passive
 mpls
exit
!
router isis SRv6
 is-type level-1
 net 49.0001.0001.0001.00
 lsp-mtu 1300
 topology ipv6-unicast
exit
!
end

FRR-2

frr version 8.4.1
frr defaults traditional
hostname FRR-2
log syslog informational
!
interface eth0
 ipv6 address 2001:db8:26::2/64
 ipv6 router isis SRv6
 isis circuit-type level-1
exit
!
interface eth1
 ipv6 address 2001:db8:12::2/64
 ipv6 router isis SRv6
 isis circuit-type level-1
exit
!
interface lo
 ipv6 address 2001:db8:22::2/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 isis passive
 mpls
exit
!
router isis SRv6
 is-type level-1
 net 49.0001.0001.0002.00
 lsp-mtu 1300
 topology ipv6-unicast
exit
!
end

FRR-3

frr version 8.4.1
frr defaults traditional
hostname FRR3n
log syslog informational
service integrated-vtysh-config
!
interface eth3
 ip address 172.16.11.3/24
 ipv6 address 2001:cafe:11::3/64
 ipv6 ospf6 area 0
 mpls
exit
!
interface eth4
 description VRF Client2 (configured at linux level)
 ip address 172.16.21.3/24
 ipv6 address 2001:cafe:21::3/64
 ipv6 ospf6 area 0
 mpls
exit
!
interface eth0
 ipv6 address 2001:db8:31::3/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 mpls
exit
!
interface eth1
 ipv6 address 2001:db8:34::3/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 mpls
exit
!
interface eth2
 mpls
exit
!
interface lo
 ipv6 address 2001:db8:33::3/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 isis passive
 mpls
exit
!
interface lo1
 ipv6 address 2001:dead:30::1/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 isis passive
exit
!
router bgp 65000
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 bgp graceful-restart
 neighbor 2001:db8:66::6 remote-as 65000
 neighbor 2001:db8:66::6 description FRR-6
 neighbor 2001:db8:66::6 update-source lo
 neighbor 2001:db8:66::6 capability extended-nexthop
 !
 segment-routing srv6
  locator FRR3
 exit
 !
 address-family ipv4 unicast
  neighbor 2001:db8:66::6 activate
 exit-address-family
 !
 address-family ipv4 vpn
  neighbor 2001:db8:66::6 activate
 exit-address-family
 !
 address-family ipv6 unicast
  network 2001:dead:30::/64
  aggregate-address 2001:dead:30::/64 summary-only
  neighbor 2001:db8:66::6 activate
 exit-address-family
 !
 address-family ipv6 vpn
  neighbor 2001:db8:66::6 activate
 exit-address-family
exit
!
router bgp 65000 vrf Client1
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 bgp graceful-restart
 !
 address-family ipv4 unicast
  redistribute connected
  redistribute ospf
  sid vpn export auto
  rd vpn export 65000:1
  nexthop vpn export 2001:dead:30::
  rt vpn both 65000:1
  export vpn
  import vpn
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute connected
  redistribute ospf6
  sid vpn export auto
  rd vpn export 65000:1
  nexthop vpn export 2001:dead:30::
  rt vpn both 65000:1
  export vpn
  import vpn
 exit-address-family
exit
!
router bgp 65000 vrf Client2
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 bgp graceful-restart
 !
 address-family ipv4 unicast
  redistribute connected
  redistribute ospf
  sid vpn export auto
  rd vpn export 65000:2
  nexthop vpn export 2001:dead:30::
  rt vpn both 65000:2
  export vpn
  import vpn
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute connected
  redistribute ospf6
  sid vpn export auto
  rd vpn export 65000:2
  nexthop vpn export 2001:dead:30::
  rt vpn both 65000:2
  export vpn
  import vpn
 exit-address-family
exit
!
router ospf vrf Client1
 ospf router-id 3.3.3.3
 redistribute bgp
 network 172.16.11.0/24 area 0
 default-information originate always
exit
!
router ospf vrf Client2
 ospf router-id 3.3.3.3
 redistribute bgp
 network 172.16.21.0/24 area 0
 default-information originate always
exit
!
router ospf6 vrf Client1
 ospf6 router-id 3.3.3.3
 redistribute bgp
 default-information originate always
exit
!
router ospf6 vrf Client2
 ospf6 router-id 3.3.3.3
 redistribute bgp
 default-information originate always
exit
!
router isis SRv6
 is-type level-1
 net 49.0001.0001.0003.00
 lsp-mtu 1300
 topology ipv6-unicast
 segment-routing on
 segment-routing node-msd 8
exit
!
segment-routing
 srv6
  locators
   locator FRR3
    prefix 2001:dead:30::/64
   exit
   !
  exit
  !
 exit
 !
exit
!
end

FRR-4

frr version 8.4.1
frr defaults traditional
hostname FRR4
log syslog informational
service integrated-vtysh-config
!
interface eth3
 mpls
exit
!
interface eth4
 mpls
exit
!
interface eth0
 ipv6 address 2001:db8:45::4/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 mpls
exit
!
interface eth1
 ipv6 address 2001:db8:34::4/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 mpls
exit
!
interface eth2
 mpls
exit
!
interface lo
 mpls
exit
!
router isis SRv6
 is-type level-1
 net 49.0001.0001.0004.00
 lsp-mtu 1300
 topology ipv6-unicast
exit
!
end

FRR-5

frr version 8.4.1
frr defaults traditional
hostname FRR5
log syslog informational
service integrated-vtysh-config
!
interface eth3
 mpls
exit
!
interface eth4
 mpls
exit
!
interface eth0
 ipv6 address 2001:db8:45::5/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 mpls
exit
!
interface eth1
 ipv6 address 2001:db8:56::5/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 mpls
exit
!
interface eth2
 ipv6 address 2001:db8:15::5/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 mpls
exit
!
interface lo
 mpls
exit
!
router isis SRv6
 is-type level-1
 net 49.0001.0001.0005.00
 lsp-mtu 1300
 topology ipv6-unicast
exit
!
end

FRR-6

!
frr version 8.4.1
frr defaults traditional
hostname frr841
log syslog informational
service integrated-vtysh-config
!
interface eth3
 description Part of VRF Client1 (configured at linux level)
 ip address 172.16.12.6/24
 ipv6 address 2001:cafe:12::6/64
 ipv6 ospf6 area 0
 mpls
exit
!
interface eth4
 description Part of VRF Client2 (configured at linux level)
 ip address 172.16.22.6/24
 ipv6 address 2001:cafe:22::6/64
 ipv6 ospf6 area 0
 mpls
exit
!
interface eth0
 ipv6 address 2001:db8:26::6/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 mpls
exit
!
interface eth1
 ipv6 address 2001:db8:56::6/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 mpls
exit
!
interface eth2
 mpls
exit
!
interface lo
 ipv6 address 2001:db8:66::6/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 isis passive
 mpls
exit
!
interface lo1
 ipv6 address 2001:dead:60::1/64
 ipv6 router isis SRv6
 isis circuit-type level-1
 isis passive
exit
!
router bgp 65000
 bgp router-id 6.6.6.6
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 bgp graceful-restart
 neighbor 2001:db8:33::3 remote-as 65000
 neighbor 2001:db8:33::3 description FRR-3
 neighbor 2001:db8:33::3 update-source lo
 neighbor 2001:db8:33::3 capability extended-nexthop
 !
 segment-routing srv6
  locator FRR6
 exit
 !
 address-family ipv4 vpn
  neighbor 2001:db8:33::3 activate
 exit-address-family
 !
 address-family ipv6 unicast
  network 2001:dead:60::/64
  aggregate-address 2001:dead:60::/64 summary-only
  neighbor 2001:db8:33::3 activate
 exit-address-family
 !
 address-family ipv6 vpn
  neighbor 2001:db8:33::3 activate
 exit-address-family
exit
!
router bgp 65000 vrf Client1
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 bgp graceful-restart
 !
 address-family ipv4 unicast
  redistribute connected
  redistribute ospf
  sid vpn export auto
  rd vpn export 65000:1
  nexthop vpn export 2001:dead:60::
  rt vpn both 65000:1
  export vpn
  import vpn
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute connected
  redistribute ospf6
  sid vpn export auto
  rd vpn export 65000:1
  nexthop vpn export 2001:dead:60::
  rt vpn both 65000:1
  export vpn
  import vpn
 exit-address-family
exit
!
router bgp 65000 vrf Client2
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 bgp graceful-restart
 !
 address-family ipv4 unicast
  redistribute connected
  redistribute ospf
  sid vpn export auto
  rd vpn export 65000:2
  nexthop vpn export 2001:dead:60::
  rt vpn both 65000:2
  export vpn
  import vpn
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute connected
  redistribute ospf6
  sid vpn export auto
  rd vpn export 65000:2
  nexthop vpn export 2001:dead:60::
  rt vpn both 65000:2
  export vpn
  import vpn
 exit-address-family
exit
!
router ospf vrf Client1
 ospf router-id 6.6.6.6
 redistribute bgp
 network 172.16.12.0/24 area 0
 default-information originate always
exit
!
router ospf vrf Client2
 ospf router-id 6.6.6.6
 redistribute bgp
 network 172.16.22.0/24 area 0
 default-information originate always
exit
!
router ospf6 vrf Client1
 ospf6 router-id 6.6.6.6
 redistribute bgp
 default-information originate always
exit
!
router ospf6 vrf Client2
 ospf6 router-id 6.6.6.6
 redistribute bgp
 default-information originate always
exit
!
router isis SRv6
 is-type level-1
 net 49.0001.0001.0006.00
 lsp-mtu 1300
 topology ipv6-unicast
 segment-routing on
 segment-routing node-msd 8
exit
!
segment-routing
 srv6
  locators
   locator FRR6
    prefix 2001:dead:60::/64
   exit
   !
  exit
  !
 exit
 !
exit
!
end

Dernière mise à jour: 3 October 2023